telo HUB is dead...

Got something else to discuss that is not covered by the previous forums? Post it here!

telo HUB is dead...

Postby hondo777 » Fri Jan 01, 2010 10:12 pm

I came home from work 2 days ago and there were no lights on the hub. I tried plugging it into a couple of different outlets but its completely dead. I called support they said someone from tier 2 support would call me back in 24 hours (they didn't). I called them back and I couldn't hardly understand the rep (his english was terrible) but he told me to send the unit to ooma. I asked for a RMA# and he said he would email the RMA# with a addess. I've never received the email and I'm concerned about sending the unit and getting a replacement, not to mention I have no service. Anyone have any suggestions?
hondo777
 
Posts: 10
Joined: Tue Dec 15, 2009 8:53 pm

Re: telo HUB is dead...

Postby Davesworld » Fri Jan 01, 2010 10:22 pm

The telo and hub are two separate products. I'm sure you confused the hell out of customer service. If the unit is black and has a touchpad on the face, it's a telo, if it is white and silver with real buttons, it's a hub.
User avatar
Davesworld
 
Posts: 343
Joined: Sun Sep 27, 2009 6:06 pm
Location: Everett, Wa

Re: telo HUB is dead...

Postby hondo777 » Fri Jan 01, 2010 10:28 pm

I don't think I called it a telo hub when I talked to them. I just said the hub was dead and CS guy looked up my information from the registration and we went from there.
hondo777
 
Posts: 10
Joined: Tue Dec 15, 2009 8:53 pm

Re: telo HUB is dead...

Postby Davesworld » Fri Jan 01, 2010 10:33 pm

hondo777 wrote:I don't think I called it a telo hub when I talked to them. I just said the hub was dead and CS guy looked up my information from the registration and we went from there.


That should have did it. Now I'm curious if you have a telo or a hub?
User avatar
Davesworld
 
Posts: 343
Joined: Sun Sep 27, 2009 6:06 pm
Location: Everett, Wa

Re: telo HUB is dead...

Postby hondo777 » Fri Jan 01, 2010 10:39 pm

It's a telo. I'm not sure why it died? We haven't had any storms or power outtages. I had it plugged into a surge protector. it also has a extremely short power plug and kept coming out of the back of the telo.
hondo777
 
Posts: 10
Joined: Tue Dec 15, 2009 8:53 pm

Re: telo HUB is dead...

Postby allo » Fri Jan 01, 2010 10:46 pm

hondo777 wrote:I don't think I called it a telo hub when I talked to them. I just said the hub was dead and CS guy looked up my information from the registration and we went from there.


Sorry to hear about the problem with the Telo...
How long since you bought it?
If it is only since you joined (12/16/09); then it is better to return it to your place of purchase and get a new one, rather than contacting ooma, unless you bought it from them; and it would be a lot faster.
allo
 
Posts: 250
Joined: Sun Oct 04, 2009 5:58 am
Location: FL

Re: telo HUB is dead...

Postby Davesworld » Fri Jan 01, 2010 11:33 pm

Yup, that loose connector. There is a post here on how to get that replaced but I doubt this is your issue. If you can never get it to power up regardless of wiggling the connector or not, it died.
User avatar
Davesworld
 
Posts: 343
Joined: Sun Sep 27, 2009 6:06 pm
Location: Everett, Wa

Re: telo HUB is dead...

Postby hondo777 » Sat Jan 02, 2010 12:25 am

I bought it on Black Friday 11/27. Newegg was running a deal for 199.00 + free shipping. It's too late to send it back to them. I'll CS again when they open and see if I can get any further on this.
hondo777
 
Posts: 10
Joined: Tue Dec 15, 2009 8:53 pm

Re: telo HUB is dead...

Postby allo » Sat Jan 02, 2010 1:29 am

hondo777 wrote:I bought it on Black Friday 11/27. Newegg was running a deal for 199.00 + free shipping. It's too late to send it back to them. I'll CS again when they open and see if I can get any further on this.


Yes, you should contact Newegg... you bought it on 11/27 but you received it a few days later... so they may exchange it for you, because it is still within the 30days range... since it happened within holidays and there was no way to contact them on new year's eve!
Newegg will go the extra mile to solve unusual problems, I think!
If you can't call them 1/2/10... send an email to let them know about it ... don't wait until Monday... because that way your email will be dated 1/2/10.
allo
 
Posts: 250
Joined: Sun Oct 04, 2009 5:58 am
Location: FL

Re: telo HUB is dead...

Postby Davesworld » Sat Jan 02, 2010 1:53 am

Newegg is pretty good about these things, they may even send a replacement while waiting for the other.
User avatar
Davesworld
 
Posts: 343
Joined: Sun Sep 27, 2009 6:06 pm
Location: Everett, Wa

Next

Return to Other Support Topics

Who is online

Users browsing this forum: lbmofo and 1 guest